500 error when accessing statements via the portal.

Incident Report for Spring Arbor University

Resolved

Statements are again available. Service is fully restored.
Posted Jun 17, 2025 - 12:15 EDT

Investigating

We are currently investigating this issue.
Posted Jun 17, 2025 - 11:47 EDT
This incident affected: CARS / MySAU Portal (MySAU Portal, CARS / Jenzabar CX).