Spring 2026 Payment Plans - Unavailable

Incident Report for Spring Arbor University

Resolved

Payment plans for Spring 2026 are now fully available. Thank you for your patience while we worked through this issue!
Posted Dec 04, 2025 - 12:02 EST

Investigating

Payment plans for Spring 2026 are currently unavailable. We’re working to resolve this as quickly as possible and will notify you as soon as they become available. Thank you for your patience.
Posted Dec 03, 2025 - 13:05 EST